[Agda] Re: Building Agda with ghc-6.12.3: build failure on geniplate

Guillaume Brunerie guillaume.brunerie at gmail.com
Wed Oct 10 22:57:01 CEST 2012

On 2012/10/10 Guillaume Brunerie <guillaume.brunerie at gmail.com> wrote:
> Hello,
> I’m trying to build Agda with ghc-6.12.3 (on the computers of the
> Institute for Advanced Study), but geniplate- fails to build.
> I’ve searched on Internet and it seems that this problem is known and
> that Nils Anders Danielsson has already sent a patch to make geniplate
> build with ghc-6.12.3 but this patch does not seem to have been
> applied upstream and I can’t find it anywhere.
> Where can I find this patch?
> Thank you,
> Guillaume Brunerie

Just to be more complete, I tried to build geniplate-,
geniplate- and geniplate- with ghc-6.12.3 and
cabal-install-0.14.0 (the latest version of cabal-install does not
compile with ghc-6.12.3) and I get the same error each time (with
different line numbers):

$ HOME=~/Agda cabal install geniplate
Warning: Falling back to topdown solver for GHC < 7.
Resolving dependencies...
Configuring geniplate-
Building geniplate-
Preprocessing library geniplate-
[1 of 1] Compiling Data.Generics.Geniplate (
Data/Generics/Geniplate.hs, dist/build/Data/Generics/Geniplate.o )

    `qClassInstances' is not a (visible) method of class `Quasi'

Data/Generics/Geniplate.hs:137:31: Not in scope: `qClassInstances'
cabal: Error: some packages failed to install:
geniplate- failed during the building phase. The exception was:
ExitFailure 1

Thank you,


More information about the Agda mailing list